Zendesk app tools - Known issues Follow

Comments

24 comments

  • Avatar
    PrestaEdit

    Bonsoir,

    J'utilise depuis peu l'outil ZAT et j'ai un soucis avec la commande validate. En effet, il me mentionne un paramètre déprécié et ensuite me mentionne que le app.js ainsi que le manifest.json n'est pas présent.

    Or, ils sont bien là. Et l'application est fonctionnelle dans Zendesk.

    Je suis sous Windows. Une idée éventuelle ? :)

  • Avatar
    Pablo

    Bonjour, Je vous contacte sur un ticket support pour obtenir plus de détails quant à votre configuration ZAT. Merci ! 

  • Avatar
    Kevin Christensen

    Had trouble installing on Debian, kept getting:

    Building native extensions. This could take a while...
    ERROR: Error installing zendesk\_apps\_tools:
    ERROR: Failed to build gem native extension.

    After some googling, found this this SO answer: http://stackoverflow.com/questions/12552929/failed-to-build-gem-native-extension-rails-install

    `mkmf`  is part of the  `ruby1.9.1-dev`  package. This package contains the header files needed for extension libraries for Ruby 1.9.1. You need to install the  `ruby1.9.1-dev`  package by doing:

    sudo apt-get install ruby1.9.1-dev

  • Avatar
    Sean Kinney

    Thanks for sharing your solution, Kevin! This is the same cause as the errors listed above for Mac OS X and Windows so it's great to have a solution for Debian as well.

  • Avatar
    Loïc DUBART

    Hello,

    I'm starting with the zendesk applications tools and i'm getting some trouble after successfully installed zat on my Windows 7 64 bits system. When running the zat new command i get the following error:

    C:\Users\ldubart\Documents\zendesk>zat new
    C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require':
    C:/Ruby193/lib/ruby/gems/1.9.1/gems/zendesk_apps_tools-1.22.1/lib/zendesk_apps_tools/manifest_handler.rb:3: unknown type of %string (SyntaxError)
    VERSION_PARTS = %i(major minor patch)
    ^
    C:/Ruby193/lib/ruby/gems/1.9.1/gems/zendesk_apps_tools-1.22.1/lib/zendesk_apps_tools/manifest_handler.rb:3: syntax error, unexpected $end
    VERSION_PARTS = %i(major minor patch)
    ^
    from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from C:/Ruby193/lib/ruby/gems/1.9.1/gems/zendesk_apps_tools-1.22.1/lib/zendesk_apps_tools/bump.rb:4:in `'
    from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from C:/Ruby193/lib/ruby/gems/1.9.1/gems/zendesk_apps_tools-1.22.1/lib/zendesk_apps_tools/command_helpers.rb:9:in `'
    from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from C:/Ruby193/lib/ruby/gems/1.9.1/gems/zendesk_apps_tools-1.22.1/lib/zendesk_apps_tools/command.rb:10:in `'
    from C:/Ruby193/lib/ruby/gems/1.9.1/gems/zendesk_apps_tools-1.22.1/bin/zat:5:in `'
    from C:/Ruby193/bin/zat:23:in `load'
    from C:/Ruby193/bin/zat:23:in `'

    What did I missed?
    Thanks in advance for your help

  • Avatar
    Shanya Almafeta

    I have the same error as Loïc, with the carat pointing at 'major' in both cases.

  • Avatar
    nutanc

    Same error as Loic. Looks like the latest release messed something up.

  • Avatar
    Loïc DUBART

    Hi again,

    I notice a ticket has been created following my comment but I'm not able to access it. Please let us know when the problem will be solved.

  • Avatar
    Loïc DUBART

    Hi there,

    A workaround solution is to uninstall this version of ZAT which is quiet new and to install an older version. The version 1.22.0 is giving the same error so install version 1.21.5

    To do so, here are the command to use:
    gem uninstall zendesk_apps_tools
    gem install zendesk_apps_tools -v 1.21.5

  • Avatar
    Jessie Schutz

    Hi Loic!

    I requested a ticket on your post so someone from our Support team can take a look at it and get an answer for you guys. It's currently with our Tier 2 team; someone will be posting here when they have some information for you!

  • Avatar
    Shanya Almafeta

    Jessie - any news?

    Same error happens with zat validate and zat package.

  • Avatar
    Dan B.

    Hi everyone,

    Thanks for your posts here!

    We have identified an issue with a feature we are using in Ruby 2.0 that breaks Ruby 1.9. We will be escalating this to our engineering team for advice.

    Until then, the workaround is to:
    a. Upgrade to Ruby 2.0, or...
    b. Install an older version of ZAT (Zendesk Apps Tools), such as version 1.21.5.

    We will post an update here when have a solution.

    Thanks!

  • Avatar
    Dan B.

    Hi everyone,

    An update on where things stand with Ruby 2.0 and ZAT.

    If you need to be using Ruby 1.9, please install ZAT 1.21.5. But please be aware that support has been discontinued for this Ruby version (https://www.ruby-lang.org/en/news/2014/11/13/ruby-1-9-3-p551-is-released/). From now on we are only supporting 2.0+.

    Our new version of ZAT is 1.22.2 that restricts Ruby version to 2.0+. Versions 1.22.0 and 1.22.1 have been removed from our repository.

    We have realized that the restriction should have been made sooner and apologize for any inconvenience this has caused you. If you have any further questions, please don't hesitate to log a support ticket with us at support@zendesk.com.

  • Avatar
    EricDahl

    Dan, I'm getting an error when I try 'zat bump major'

    ericdahaptop755:Take 5 From 5 2 edahl$ zat bump major
    /Users/edahl/.rvm/gems/ruby-2.0.0-p598/gems/zendesk_apps_tools-1.22.2/lib/zendesk_apps_tools/manifest_handler.rb:34:in `read_version': undefined method `to_h' for [[:v, nil], [:major, "0"], [:minor, "0"], [:patch, "0"]]:Array (NoMethodError)
    from /Users/edahl/.rvm/gems/ruby-2.0.0-p598/gems/zendesk_apps_tools-1.22.2/lib/zendesk_apps_tools/manifest_handler.rb:10:in `block (2 levels) in '
    from /Users/edahl/.rvm/gems/ruby-2.0.0-p598/gems/thor-0.18.1/lib/thor/command.rb:27:in `run'
    from /Users/edahl/.rvm/gems/ruby-2.0.0-p598/gems/thor-0.18.1/lib/thor/invocation.rb:120:in `invoke_command'
    from /Users/edahl/.rvm/gems/ruby-2.0.0-p598/gems/thor-0.18.1/lib/thor.rb:363:in `dispatch'
    from /Users/edahl/.rvm/gems/ruby-2.0.0-p598/gems/thor-0.18.1/lib/thor/invocation.rb:109:in `invoke'
    from /Users/edahl/.rvm/gems/ruby-2.0.0-p598/gems/thor-0.18.1/lib/thor.rb:232:in `block in subcommand'
    from /Users/edahl/.rvm/gems/ruby-2.0.0-p598/gems/thor-0.18.1/lib/thor/command.rb:27:in `run'
    from /Users/edahl/.rvm/gems/ruby-2.0.0-p598/gems/thor-0.18.1/lib/thor/invocation.rb:120:in `invoke_command'
    from /Users/edahl/.rvm/gems/ruby-2.0.0-p598/gems/thor-0.18.1/lib/thor.rb:363:in `dispatch'
    from /Users/edahl/.rvm/gems/ruby-2.0.0-p598/gems/thor-0.18.1/lib/thor/base.rb:439:in `start'
    from /Users/edahl/.rvm/gems/ruby-2.0.0-p598/gems/zendesk_apps_tools-1.22.2/bin/zat:5:in `'
    from /Users/edahl/.rvm/gems/ruby-2.0.0-p598/bin/zat:23:in `load'
    from /Users/edahl/.rvm/gems/ruby-2.0.0-p598/bin/zat:23:in `'
    from /Users/edahl/.rvm/gems/ruby-2.0.0-p598/bin/ruby_executable_hooks:15:in `eval'
    from /Users/edahl/.rvm/gems/ruby-2.0.0-p598/bin/ruby_executable_hooks:15:in `'

  • Avatar
    Dan B.

    Hi Eric!

    I've noticed you submitted a support ticket about your issue. I trust that Creighton's suggestion worked for you; if you have any further questions, please don't hesitate to reply to the ticket and re-open it.

    For anyone else who may be interested in the error Eric experienced, the 'bump' feature is relatively new and was developed for a newer version of Ruby. The feature should work perfectly if you're using Ruby 2.1.0 or above. Please upgrade your Ruby installation to take advantage of the new feature (or install rvm and rvm use 2.1.0 before using ZAT).

  • Avatar
    Robert Aronovici

    Help!

    I'm receiving this message now after updating Ruby and the gem packages...

    c:\Projects\Zendesk\pi_integration>zat validate RUBYOPT -E utf-8
    Warning: unexpected string encoding: IBM437, zat runs best in UTF-8.
    Please set the RUBYOPT environment variable to "-E utf-8".
    C:/Ruby22-x64/lib/ruby/site_ruby/2.2.0/rbreadline.rb:1097:in `<module:RbReadline>': HOME environment variable (or HOMEDRIVE and HOMEPATH) must be set and point to a directory (RuntimeError)
            from C:/Ruby22-x64/lib/ruby/site_ruby/2.2.0/rbreadline.rb:17:in `<top (required)>'
            from C:/Ruby22-x64/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
            from C:/Ruby22-x64/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
            from C:/Ruby22-x64/lib/ruby/site_ruby/2.2.0/readline.rb:10:in `<module:Readline>'
            from C:/Ruby22-x64/lib/ruby/site_ruby/2.2.0/readline.rb:8:in `<top (required)>'
            from C:/Ruby22-x64/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
            from C:/Ruby22-x64/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
            from C:/Ruby22-x64/lib/ruby/gems/2.2.0/gems/thor-0.19.4/lib/thor/line_editor/readline.rb:2:in `<top (required)>'
            from C:/Ruby22-x64/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
            from C:/Ruby22-x64/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
            from C:/Ruby22-x64/lib/ruby/gems/2.2.0/gems/thor-0.19.4/lib/thor/line_editor.rb:2:in `<top (required)>'
            from C:/Ruby22-x64/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
            from C:/Ruby22-x64/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
            from C:/Ruby22-x64/lib/ruby/gems/2.2.0/gems/thor-0.19.4/lib/thor/base.rb:8:in `<top (required)>'
            from C:/Ruby22-x64/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
            from C:/Ruby22-x64/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
            from C:/Ruby22-x64/lib/ruby/gems/2.2.0/gems/thor-0.19.4/lib/thor.rb:2:in `<top (required)>'
            from C:/Ruby22-x64/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
            from C:/Ruby22-x64/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
            from C:/Ruby22-x64/lib/ruby/gems/2.2.0/gems/zendesk_apps_tools-1.37.4/lib/zendesk_apps_tools/command.rb:1:in `<top (required)>'
            from C:/Ruby22-x64/lib/ruby/gems/2.2.0/gems/zendesk_apps_tools-1.37.4/bin/zat:13:in `<top (required)>'
            from C:/Ruby22-x64/bin/zat:22:in `load'
            from C:/Ruby22-x64/bin/zat:22:in `<main>'

    c:\Projects\Zendesk\pi_integration>ruby -v
    ruby 2.2.6p396 (2016-11-15 revision 56800) [x64-mingw32]

  • Avatar
    Andrew Dietrich

    Hi Robert, 

    I'm unfortunately not a backend (i.e. Ruby) expert, but I ran through the steps to install Ruby 2.2.6 + the ZAT gem on a fresh Windows computer, and we found two things: 

    1. We needed to install the DevKit in addition to Ruby itself, which is available on the ruby downloader site: http://rubyinstaller.org/downloads/
    2. We also had the same UTF-8 encoding error. To fix it, we ran "set RUBYOPT=-E utf-8". However that setting appears to have been applied to locally, so for convenience you may want to apply it to the top level directory.

    I also notice that in your errors, it keeps referring to Ruby 2.2.0, but I see at the end your ruby -v returns 2.2.6. Perhaps a full reinstall of Ruby would help?


    If you're still having issues, let me know and we can pull this into a ticket and hopefully loop in our developers.

  • Avatar
    Daniel Cooper

    The link under the "Failed to build gem native extension" error in Windows section isn't working anymore. 

  • Avatar
    Jessie Schutz

    Thanks for the heads-up, Daniel! I'll let our Docs team know. :)

  • Avatar
    Charles Nadeau

    @Daniel. Looks like that 3rd-party article has been taken down. I updated the section with a link to the DevKit on the RubyInstaller website. Thanks.

    Charles

  • Avatar
    Kiran Madhav

    Hi there,

    If I install ZAT v2, does it support ZAT v1 apps to validate, build etc. or should I migrate all the apps to newer version.

    Please suggest.

    Thanks,

    Kiran.

     

  • Avatar
    Joseph May

    Hi Kiran-

    You can continue to validate for v1; we aren't accepting new app submissions however - this would only apply for updates to existing, installed apps. More on that here. That said, I would recommend focusing on migrating to version 2 of the framework sooner rather than later.

    Joey

  • Avatar
    Kiran Madhav

    Hi Joseph,

     
    I hope you're very much sure on this, at any case shall we set back to old version in zat tool.
     
    It'll helpful to me if you provide cmd commands to upgrade my zat tool from v1 to v2.
     
    Thanks,
    Kiran.
  • Avatar
    Joseph May

    Hi Kiran-

    Updating Zendesk Apps Tools follows the same process of any gem update:

    $ gem update zendesk_apps_tools

    Depending on your environment, you may need to escalate privilege to update a gem. The current version is 2.3.0. To see your current version, simply run zat -v.

Please sign in to leave a comment.

Powered by Zendesk